Welcome, Guest. Please login or register.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - gderf

Pages: [1]
2
Feature Requests / SNMP Agent Upgrade to 64bit
« on: August 04, 2015, 04:17:02 PM »
The current SNMP Agent/MIB does not have any 64bit counters available.


On high speed interfaces with high throughput rates, the 32bit counters used in the current t1n1wall version wrap too quickly to be of use by programs that poll interfaces infrequently.


Current pfsense does not have this problem as it makes use of 64bit counters on the interface OIDs.


3
Services / PC Engines APU1D4 and SNMP
« on: August 02, 2015, 07:00:18 PM »
I have been using IOG http://www.dynw.com/iog/ for many years with all sorts of firewall appliances with good results even though the program is very dated.


When I transitioned from my old ALIX 2C3 to my new APU1D4, IOG continued on seemingly well with no changes required to its configuration.


But I found myself in an unusual situation, unusual for me that is' and now IOG is broken, and badly.


What happened is that I did an extensive amount of downloading over a fairly short period of time ~175GB in just a few hours. What I observed is that IOG no longer reported bandwidth usage accurately, and I man WAY OFF as in way too low.


From what I can tell the problem is caused by the SNMP OID counters for the network interfaces in the router are only 32bit capable, and are wrapping around and starting over from zero more than once during any one hour period for which IOG polls the counters.


In the past this was never seen because my usage patterns combined with the prior low speed capability of my internet service meant that I couldn't or didn't exceed the counters' capabilities in any one hour period for which IOG polls the counters.


What's happening now is that my internet connection is now capable of more than 125mbps and running it flat out easily wraps the SNMP OID counters for the network interfaces of the router, probably several times in any one hour period before they are polled again by IOG.


Does anyone have any solution to this?


I did do an SNMP walk of the APU1D4 and didn't spot any OIDs that referenced 64bit within their names.


Is this a limitation of the APU1D4 and/or is it a deficiency of the SNMP MIB that is within t1n1wall?

4
Installation / iso image file to bootable usb stick
« on: July 09, 2015, 09:00:47 PM »
I am starting with generic-pc-1.8.2b42.iso file and I use (among other things) dd to write it to an 8GB Sandisk  USB stick. However, the resulting USB drive will not boot on any machine I have.


Any ideas?





5
Installation / Anyone Running on an APU?
« on: July 04, 2015, 07:18:13 PM »
My ISP recently upgraded my service. Until that happened, my trusty old Alix 2C board with 100mbps NICs was all I needed.


Prior to the upgrade, I was provisioned for ~85mbps down and the ALIX seemed to handle that well, giving me all of it.


However, the upgrade was to ~125mbps down, and the ALIX will not deliver anymore than that same ~85mbps. I am now Bottlenecked by the NICs or CPU or both. I know this because if I plug a PBCwith 1gbs NIC directly into the modem, I get the full 125mbs down.


So I ordered an APU1D4 board and it will be here in about a week. I plan to boot it with t1n1wall on a Sandisk Cruiser Fit USB drive.


Has anyone set up for an APU? Any quirks or special handling over what works for ALIX installs?


6
I would find it useful to be able to occasionally disable/re-enable a network interface.


Obviously, this could be a problem if done from the network remotely, so restricting the capability to the serial console would be appropriate.


Currently I unplug/re-plug ethernet cables to do this.


Thanks for considering this enhancement.

7
Feature Requests / BlinkLED
« on: April 03, 2015, 04:41:10 PM »
BlinkLED is a pfsense feature that allows LEDs available on ALIX boards to be assigned to network interfaces and indicate the presence of traffic on them. Would be useful for installations where the rear panel is not visible, but the front panel is. See:


https://doc.pfsense.org/index.php/BlinkLED_Package


8
General Questions / Avatars not working in forum
« on: March 15, 2015, 12:32:32 AM »
I was able to upload an avatar when the forum first opened, but I now see that mine does not display and uploading one does not work. I checked the forum permissions for this, and it is set to allow it but I can't seem to spot the problem.

Pages: [1]