t1n1wall

t1n1wall Support (English) => Installation => Topic started by: Y.Mamoto on September 10, 2021, 12:34:51 AM

Title: Migration Problem from SmallWall to t1n1wall
Post by: Y.Mamoto on September 10, 2021, 12:34:51 AM
I need help with my new Express 5800 server.

 I can login when its newly installed but as soon as I load an old config from smallwall 1.8.4b11 to the newest t1n1wall, I can't access web interface.

 If I disable pf, I  access web interface, but the firewall doesn't work.
I've tried various things (ex. delete all static route, apply, reboot), but I'm in trouble because I can't solve it.

Please let me know if there is a workaround.
Title: Re: Migration Problem from SmallWall to t1n1wall
Post by: andywhite on September 10, 2021, 12:38:56 AM
something in the firewall rules is breaking, probably a bug.  I'd need to see your firewall rules from /status.php
Title: Re: Migration Problem from SmallWall to t1n1wall
Post by: Y.Mamoto on September 10, 2021, 04:28:43 AM
I send the results of status.php via e-mail.
Thanks.

Title: Re: Migration Problem from SmallWall to t1n1wall
Post by: Y.Mamoto on September 17, 2021, 11:06:00 AM
Hello,

After unchecking "Allow fragmented packets" of all rules,
I've solved the problem.

In the xml file, after deleting all the lines with <frags />,
and restoring the config file.
Title: Re: Migration Problem from SmallWall to t1n1wall
Post by: Y.Mamoto on September 19, 2021, 09:02:29 AM
If I check the function "Allow Fragment Packets", save and reflect the rule, the WebUI'll be locked out again.

Doesn't  the function work correctly?
Title: Re: Migration Problem from SmallWall to t1n1wall
Post by: andywhite on September 21, 2021, 11:49:23 AM
I'll take a look this weekend, hopefully a simple fix :)